Translate this page:

Welcome to our forums. Please sign-in or register

Nokia E71 and T-Mobile: Sim card not registered

Posted: 12:51 11 Sep 08 #1
  • BleuMan
  • 4 Posts
  • Join Date: 11 September 2008

I have a new E71 and T-Mobile sim card, both from expansys within the last week. I keep getting a Sim card not registered message every now and again. Leaving the phone for a while or switching off and on seems to clear it and it works normally again.

I tried reseating the sim card and thought the problem had gone away but it has just happened again. When I switched off and on again it came back with full signal strength and 3G indicators on.

The phone and sim are obviously valid, unlocked etc as they were both supplied new direct by expansys. I noticed that someone on the forums seemed to be having a similar problem with a N95. 

Any ideas what is going on here and what I can do to fix it?

Thanks.  

Posted: 14:34 13 Sep 08 #2
  • aikibrown
  • 12 Posts
  • Join Date: 13 September 2005

I have exactly the same problem with my E71. The sim card worked briefly for about an hour and then I lost network coverage and data connection then the 'Sim card registration failed' message appears all the time on the phone.

I dont think that the phone is at fault because I have two other T-Mobile Sim cards that work just fine in the E71.

I tried using this latest sim card in both of my other Nokia hand sets and still the sim card fails to register.

As I now know that I am not alone with this problem, it leads me to think that perhaps Expansys has a batch of faulty Sim cards. I have contacted T-Mobile and they have concurred that the Sim card needs to be replaced, and will send me a new one, which should arrive on monday. T- Mobile tried to convince me that perhaps I had incorrectly input a security code in the phone which consequently locked down the card.

I explained to T-Mobile that I was never prompted to enter a PUK or any other security code when starting the phone up, however they did not accept this and so I was charged £10 for the replacement Sim card. There was an inference by the customer services guy (150) that I had somehow damaged the card. In the end we agreed to differ and I paid the £10 chrge for a replacement sim card.

I will report back once I have the new Sim card to make sure that the problem is not repeated.

 Hope this helps.

@ Expansys customer support & connections dept

Please accept this email as the formal registering of a possible defect with your current stock of T-Mobile Sim cards. I would appreciate a response from Expansys to acknowledge that this is being looked into for the sake of other customers.

I have bought many phones from expansys and have never had a problem until now. I am happy with the E71 - its a damn good hand set. However I suggest that you guys send back your current stock of sim cards to T-Mobile or at the very least get them checked out, otherwise I suspect that many more expansys customers will suffer the same problem, expense (although minimal) and  inconvenience of ordering and waiting for a replacement Sim card from T-Mobile.

 

Thanks.

 

 

 

Posted: 15:48 13 Sep 08 #3
  • BleuMan
  • 4 Posts
  • Join Date: 11 September 2008
Thanks very much for posting this message. I am disappointed to say the least that no expansys representative has bothered to reply. I'll call T-Mobile but if they think I am paying for a new sim card they'll be finding themselves in court with expansys. Sad isn't it. A good opportunity to provide customer service and build loyalty wasted.... 
Posted: 16:08 13 Sep 08 #4
  • anitalg
  • 10490 Posts
  • anitalg
  • Join Date: 4 March 2006
  • Occupation: Sitting quietly in the corner
  • Location: fingers in ears singing lala

There are very few staff members who post on here - you may get a responce to a techinical question but its usually from one of the volunteer such as myself.

Yoni who handles most of the posts has been away from work.

Am sure if you hang fire more than a couple of days he will see this post. 

Posted: 20:05 16 Sep 08 #5
  • BleuMan
  • 4 Posts
  • Join Date: 11 September 2008

anitalg, thanks for the advice. It is a pity that the customer services pages direct you here for technical support if this is not the best route!

Anyway, T-Mobile have agreed to send a new sim free of charge so hopefully that will resolve the problem. If anyone else has the same issue with a T-Mobile sim do please post here so that we and they can see the pattern emerging.

Posted: 12:12 17 Sep 08 #6
  • Yoni
  • 9208 Posts
  • Yoni
  • Join Date: 14 January 2004
  • Occupation: Tech, eXpansys Ltd
  • Location: Manchester UK

BleuMan,

I have notified to contracts team of your post, and the problem.

They will contact T-mobile, and then give you a call. 

For future reference, as a contract customer you should have called the team on 0161 868 3427 and it would have been dealt with same day.

Yoni,
eXpansys Product Support,
Forum Search

Posted: 18:21 18 Sep 08 #7
  • BleuMan
  • 4 Posts
  • Join Date: 11 September 2008

Credit to expansys for the contracts team trying to get hold of me over the last couple of days. We finally spoke and they were very supportive (I still think the website should make it clear that contract customers should always call rather than post here......).

This morning the original T-Mobile sim gave up completely with Sim card registration failed as the error.

Since then the new T-Mobile sim has arrived and appears to be working just fine (about 8 hours so far) so fingers crossed!

One strange thing though, the signal strenth seems to be noticeably higher now that the new sim card is in. I would not have thought that the sim card could affect that but there is a definite improvement from very poor reception in my house to now between 2 bars downstairs and full strength (even 3G in some places) upstairs. Very odd but most welcome.  

Posted: 07:48 19 Sep 08 #8
  • Yoni
  • 9208 Posts
  • Yoni
  • Join Date: 14 January 2004
  • Occupation: Tech, eXpansys Ltd
  • Location: Manchester UK

Thanks you for taking the time to update the thread, please post back if you have further questions / comments. 

Yoni,
eXpansys Product Support,
Forum Search

Posted: 17:38 19 Sep 08 #9
  • aikibrown
  • 12 Posts
  • Join Date: 13 September 2005

OK, just a quick update.

Finally received my replacement SIM card from T-Mob and this this one is now working properly.

Have expansys confirmed that they may have a faulty batch of Sim cards yet?

Posted: 23:58 16 Oct 08 #10
  • errie806
  • 4 Posts
  • Join Date: 16 October 2008

i got my e71 with the tmobile sim card in it i got the 300 min plan with unlimited text they sed that the unlimited text inclueds aim so how do i set up instant messaging on the fone through tmobile that is included with my plan

 

Please suggest any improvements or report problems / abuse to moderator@expansys.com